problem compiling SL 1.6.11 on Ubuntu Hardy 32bit [SOLVED]

Problems getting SL up and running on Linux? Post here.

Moderator: jesse

Post Reply
kanin_te_sova
Posts: 2
Joined: Thu Oct 23, 2008 3:51 pm

problem compiling SL 1.6.11 on Ubuntu Hardy 32bit [SOLVED]

Post by kanin_te_sova »

Hello!

I love Sooperlooper like all of us here. :) THANKS FOR MAKING THIS SOFTWARE! *love*

I run Ubuntu Studio and recently upgraded to the new real-time kernel 2.6.24.21-rt.

I have been trying to compile the latest Sooperlooper 1.6.11 (I have also tried 1.6.10 and also 1.4.something...pre-rubberband) but to no avail!

I keep getting some of the following errors trying to compile (I have done this with root-privileges in the terminal):

slconsole.cpp:27:20: error: curses.h: No such file or directory
slconsole.cpp: In function ‘int do_control_change(char)’:
slconsole.cpp:126: error: ‘noraw’ was not declared in this scope
slconsole.cpp:127: error: ‘echo’ was not declared in this scope
slconsole.cpp:128: error: ‘timeout’ was not declared in this scope
slconsole.cpp:129: error: ‘curs_set’ was not declared in this scope
slconsole.cpp:134: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:135: error: ‘mvprintw’ was not declared in this scope
slconsole.cpp:136: error: ‘clrtoeol’ was not declared in this scope
slconsole.cpp:137: error: ‘refresh’ was not declared in this scope
slconsole.cpp:138: error: ‘scanw’ was not declared in this scope
slconsole.cpp:141: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:148: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:155: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:162: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:169: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:176: warning: deprecated conversion from string constant to ‘char*’
slconsole.cpp:215: error: ‘mvprintw’ was not declared in this scope
slconsole.cpp:216: error: ‘clrtoeol’ was not declared in this scope
slconsole.cpp:217: error: ‘refresh’ was not declared in this scope
slconsole.cpp:219: error: ‘raw’ was not declared in this scope
slconsole.cpp:220: error: ‘noecho’ was not declared in this scope
slconsole.cpp: In function ‘void update_values()’:
slconsole.cpp:345: error: ‘mvprintw’ was not declared in this scope
slconsole.cpp:348: error: ‘printw’ was not declared in this scope
slconsole.cpp: In function ‘void cleanup()’:
slconsole.cpp:375: error: ‘endwin’ was not declared in this scope
slconsole.cpp: In function ‘int main(int, char**)’:
slconsole.cpp:449: error: ‘initscr’ was not declared in this scope
slconsole.cpp:453: error: ‘raw’ was not declared in this scope
slconsole.cpp:454: error: ‘stdscr’ was not declared in this scope
slconsole.cpp:454: error: ‘TRUE’ was not declared in this scope
slconsole.cpp:454: error: ‘keypad’ was not declared in this scope
slconsole.cpp:455: error: ‘noecho’ was not declared in this scope
slconsole.cpp:456: error: ‘curs_set’ was not declared in this scope
slconsole.cpp:458: error: ‘printw’ was not declared in this scope
slconsole.cpp:471: error: ‘refresh’ was not declared in this scope
slconsole.cpp:474: error: ‘timeout’ was not declared in this scope
slconsole.cpp:478: error: ‘getch’ was not declared in this scope
slconsole.cpp:481: error: ‘ERR’ was not declared in this scope
slconsole.cpp:514: error: ‘endwin’ was not declared in this scope
make[2]: *** [slconsole.o] Error 1
make[2]: Leaving directory `/home/emil/Desktop/sooperlooper-1.6.11/src'
make[1]: *** [install-recursive] Error 1

I have fixed all dependencies (I think)... and the ./configure command does not make fuss about it... but still these problems

My previous install of SL runs fine still, fortunatly ;)

Could someone PLZ help?

I'm more musician than software developer he he :P ...

Thank YOU if this can be solved!!! And maybe - in the future, if someone else runs into this - they TOO can fix it... :)

Love //emil


P.S.

Will this new version have Time-Stretch capabilities? I mean Rubberband.... That sounds nice! :geek:
Last edited by kanin_te_sova on Fri Oct 24, 2008 12:13 pm, edited 1 time in total.

jesse
Posts: 524
Joined: Sat Sep 06, 2008 9:46 am
Contact:

Re: problem compiling SL 1.6.11 on Ubuntu Hardy 32bit

Post by jesse »

Looks like you are missing the ncurses-dev package. Sorry that configure doesn't warn you about that.

kanin_te_sova
Posts: 2
Joined: Thu Oct 23, 2008 3:51 pm

Re: problem compiling SL 1.6.11 on Ubuntu Hardy 32bit

Post by kanin_te_sova »

Wow, thanks Jesse!

That was a quick reply. Really appreciate it!!! :D

PROBLEM SOLVED!

It was that package I needed!

:) :) :)

Now music making again!!!


Regards!!!


//emil

^rooker
Posts: 2
Joined: Sun Sep 07, 2008 7:02 am

Re: problem compiling SL 1.6.11 on Ubuntu Hardy 32bit [SOLVED]

Post by ^rooker »

For others that might want to use the newest SL with Hardy 32bit, install these 2 .deb packages:

librubberband2
sooperlooper 1.6.11 (i386)


Optional
For those who want to build SL themselves, but don't want to bother compiling its dependencies, get these packages:
librubberband-dev

Download vamp sdk from future-ubuntu repositories:
http://packages.ubuntu.com/search?suite ... words=vamp
(you need vamp-plugin-sdk, libvamp-sdk1, libvamp-hostsdk2)

Post Reply